aboutsummaryrefslogtreecommitdiff
path: root/crates/ssr/Cargo.toml
diff options
context:
space:
mode:
authorDmitry <[email protected]>2020-08-14 19:32:05 +0100
committerDmitry <[email protected]>2020-08-14 19:32:05 +0100
commit178c3e135a2a249692f7784712492e7884ae0c00 (patch)
treeac6b769dbf7162150caa0c1624786a4dd79ff3be /crates/ssr/Cargo.toml
parent06ff8e6c760ff05f10e868b5d1f9d79e42fbb49c (diff)
parentc2594daf2974dbd4ce3d9b7ec72481764abaceb5 (diff)
Merge remote-tracking branch 'origin/master'
Diffstat (limited to 'crates/ssr/Cargo.toml')
-rw-r--r--crates/ssr/Cargo.toml24
1 files changed, 24 insertions, 0 deletions
diff --git a/crates/ssr/Cargo.toml b/crates/ssr/Cargo.toml
new file mode 100644
index 000000000..56c1f7761
--- /dev/null
+++ b/crates/ssr/Cargo.toml
@@ -0,0 +1,24 @@
1[package]
2name = "ssr"
3version = "0.0.0"
4description = "Structural search and replace of Rust code"
5license = "MIT OR Apache-2.0"
6repository = "https://github.com/rust-analyzer/rust-analyzer"
7authors = ["rust-analyzer developers"]
8edition = "2018"
9
10[lib]
11doctest = false
12
13[dependencies]
14rustc-hash = "1.1.0"
15
16text_edit = { path = "../text_edit" }
17syntax = { path = "../syntax" }
18base_db = { path = "../base_db" }
19ide_db = { path = "../ide_db" }
20hir = { path = "../hir" }
21test_utils = { path = "../test_utils" }
22
23[dev-dependencies]
24expect = { path = "../expect" }