aboutsummaryrefslogtreecommitdiff
path: root/crates/ssr/Cargo.toml
diff options
context:
space:
mode:
authorbors[bot] <26634292+bors[bot]@users.noreply.github.com>2020-08-18 11:52:27 +0100
committerGitHub <[email protected]>2020-08-18 11:52:27 +0100
commita95c5e21219cd6569e2630637fd4268e24c0ca03 (patch)
tree8f8d7348d4916479396abb58adc6891163cb9cbc /crates/ssr/Cargo.toml
parent5d97db8d480d58559e7490e1efdb0e45d1a8832f (diff)
parent29e6238cb7330f7d29f33ff03a4ccc0a0cec9f4d (diff)
Merge #5758
5758: SSR: Explicitly autoderef and ref placeholders as needed r=matklad a=davidlattimore Structural search replace now inserts *, & and &mut in the replacement to match any auto[de]ref in the matched code. e.g. `$a.foo() ==>> bar($a)` might convert `x.foo()` to `bar(&mut x)` Co-authored-by: David Lattimore <[email protected]>
Diffstat (limited to 'crates/ssr/Cargo.toml')
-rw-r--r--crates/ssr/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/crates/ssr/Cargo.toml b/crates/ssr/Cargo.toml
index 56c1f7761..7c2090de3 100644
--- a/crates/ssr/Cargo.toml
+++ b/crates/ssr/Cargo.toml
@@ -12,6 +12,7 @@ doctest = false
12 12
13[dependencies] 13[dependencies]
14rustc-hash = "1.1.0" 14rustc-hash = "1.1.0"
15itertools = "0.9.0"
15 16
16text_edit = { path = "../text_edit" } 17text_edit = { path = "../text_edit" }
17syntax = { path = "../syntax" } 18syntax = { path = "../syntax" }