aboutsummaryrefslogtreecommitdiff
path: root/crates/stdx/Cargo.toml
diff options
context:
space:
mode:
authorAleksey Kladov <[email protected]>2021-04-20 14:06:20 +0100
committerAleksey Kladov <[email protected]>2021-04-20 16:02:54 +0100
commit1772eb0f1a5c714c91f8ae45cc67cbae6b7ff348 (patch)
treec7498a99c42a9fd30b437cc12e66c5093f8b4d6b /crates/stdx/Cargo.toml
parent1834938d6f37c0d308e407e50514180d0f08d96f (diff)
fix: no longer get stuck on windows
reading both stdout & stderr is a common gotcha, you need to drain them concurrently to avoid deadlocks. Not sure why I didn't do the right thing from the start. Seems like I assumed the stderr is short? That's not the case when cargo spams `compiling xyz` messages
Diffstat (limited to 'crates/stdx/Cargo.toml')
-rw-r--r--crates/stdx/Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/crates/stdx/Cargo.toml b/crates/stdx/Cargo.toml
index d28b5e658..f78c5da7c 100644
--- a/crates/stdx/Cargo.toml
+++ b/crates/stdx/Cargo.toml
@@ -10,10 +10,15 @@ edition = "2018"
10doctest = false 10doctest = false
11 11
12[dependencies] 12[dependencies]
13libc = "0.2.93"
13backtrace = { version = "0.3.44", optional = true } 14backtrace = { version = "0.3.44", optional = true }
14always-assert = { version = "0.1.2", features = ["log"] } 15always-assert = { version = "0.1.2", features = ["log"] }
15# Think twice before adding anything here 16# Think twice before adding anything here
16 17
18[target.'cfg(windows)'.dependencies]
19miow = "0.3.6"
20winapi = "0.3.9"
21
17[features] 22[features]
18# Uncomment to enable for the whole crate graph 23# Uncomment to enable for the whole crate graph
19# default = [ "backtrace" ] 24# default = [ "backtrace" ]