aboutsummaryrefslogtreecommitdiff
path: root/crates/syntax/Cargo.toml
diff options
context:
space:
mode:
authorAleksey Kladov <[email protected]>2021-01-20 11:04:53 +0000
committerAleksey Kladov <[email protected]>2021-01-20 11:04:53 +0000
commit3429b32ad119756985e1a7bfa5e9e53042671f8b (patch)
treec73e213a5a1a2b7a344d7f5860edfd9531dfb65d /crates/syntax/Cargo.toml
parent46b4f89c920c314caf1a8af2abdb09732d100d67 (diff)
:arrow_up: rowan
It now stores text inline with tokens
Diffstat (limited to 'crates/syntax/Cargo.toml')
-rw-r--r--crates/syntax/Cargo.toml5
1 files changed, 1 insertions, 4 deletions
diff --git a/crates/syntax/Cargo.toml b/crates/syntax/Cargo.toml
index 165533388..55b437a3a 100644
--- a/crates/syntax/Cargo.toml
+++ b/crates/syntax/Cargo.toml
@@ -12,15 +12,12 @@ doctest = false
12 12
13[dependencies] 13[dependencies]
14itertools = "0.10.0" 14itertools = "0.10.0"
15rowan = { path="../../../rowan" } 15rowan = "0.12"
16rustc_lexer = { version = "697.0.0", package = "rustc-ap-rustc_lexer" } 16rustc_lexer = { version = "697.0.0", package = "rustc-ap-rustc_lexer" }
17rustc-hash = "1.1.0" 17rustc-hash = "1.1.0"
18arrayvec = "0.5.1" 18arrayvec = "0.5.1"
19once_cell = "1.3.1" 19once_cell = "1.3.1"
20indexmap = "1.4.0" 20indexmap = "1.4.0"
21# This crate transitively depends on `smol_str` via `rowan`.
22# ideally, `serde` should be enabled by `rust-analyzer`, but we enable it here
23# to reduce number of compilations
24smol_str = { version = "0.1.15", features = ["serde"] } 21smol_str = { version = "0.1.15", features = ["serde"] }
25serde = { version = "1.0.106", features = ["derive"] } 22serde = { version = "1.0.106", features = ["derive"] }
26 23