diff options
author | Igor Aleksanov <[email protected]> | 2020-08-14 05:34:07 +0100 |
---|---|---|
committer | Igor Aleksanov <[email protected]> | 2020-08-14 05:34:07 +0100 |
commit | c26c911ec1e6c2ad1dcb7d155a6a1d528839ad1a (patch) | |
tree | 7cff36c38234be0afb65273146d8247083a5cfeb /crates/syntax/Cargo.toml | |
parent | 3c018bf84de5c693b5ee1c6bec0fed3b201c2060 (diff) | |
parent | f1f73649a686dc6e6449afc35e0fa6fed00e225d (diff) |
Merge branch 'master' into add-disable-diagnostics
Diffstat (limited to 'crates/syntax/Cargo.toml')
-rw-r--r-- | crates/syntax/Cargo.toml | 35 |
1 files changed, 35 insertions, 0 deletions
diff --git a/crates/syntax/Cargo.toml b/crates/syntax/Cargo.toml new file mode 100644 index 000000000..47e351f9d --- /dev/null +++ b/crates/syntax/Cargo.toml | |||
@@ -0,0 +1,35 @@ | |||
1 | [package] | ||
2 | name = "syntax" | ||
3 | version = "0.0.0" | ||
4 | description = "Comment and whitespace preserving parser for the Rust language" | ||
5 | license = "MIT OR Apache-2.0" | ||
6 | repository = "https://github.com/rust-analyzer/rust-analyzer" | ||
7 | authors = ["rust-analyzer developers"] | ||
8 | edition = "2018" | ||
9 | |||
10 | [lib] | ||
11 | doctest = false | ||
12 | |||
13 | [dependencies] | ||
14 | itertools = "0.9.0" | ||
15 | rowan = "0.10.0" | ||
16 | rustc_lexer = { version = "671.0.0", package = "rustc-ap-rustc_lexer" } | ||
17 | rustc-hash = "1.1.0" | ||
18 | arrayvec = "0.5.1" | ||
19 | once_cell = "1.3.1" | ||
20 | # This crate transitively depends on `smol_str` via `rowan`. | ||
21 | # ideally, `serde` should be enabled by `rust-analyzer`, but we enable it here | ||
22 | # to reduce number of compilations | ||
23 | smol_str = { version = "0.1.15", features = ["serde"] } | ||
24 | serde = { version = "1.0.106", features = ["derive"] } | ||
25 | |||
26 | stdx = { path = "../stdx" } | ||
27 | text_edit = { path = "../text_edit" } | ||
28 | parser = { path = "../parser" } | ||
29 | |||
30 | [dev-dependencies] | ||
31 | walkdir = "2.3.1" | ||
32 | rayon = "1" | ||
33 | |||
34 | test_utils = { path = "../test_utils" } | ||
35 | expect = { path = "../expect" } | ||