aboutsummaryrefslogtreecommitdiff
path: root/crates/syntax/Cargo.toml
diff options
context:
space:
mode:
authorbors[bot] <26634292+bors[bot]@users.noreply.github.com>2020-08-12 17:31:42 +0100
committerGitHub <[email protected]>2020-08-12 17:31:42 +0100
commitd583f2c46d22cf8d643ebf98be9cb7059a304431 (patch)
tree9d898eb9600b0c36a74e4f95238f679c683fa566 /crates/syntax/Cargo.toml
parent3d6889cba72a9d02199f7adaa2ecc69bc30af834 (diff)
parenta1c187eef3ba08076aedb5154929f7eda8d1b424 (diff)
Merge #5729
5729: Rename ra_syntax -> syntax r=matklad a=matklad bors r+ 🤖 Co-authored-by: Aleksey Kladov <[email protected]>
Diffstat (limited to 'crates/syntax/Cargo.toml')
-rw-r--r--crates/syntax/Cargo.toml35
1 files changed, 35 insertions, 0 deletions
diff --git a/crates/syntax/Cargo.toml b/crates/syntax/Cargo.toml
new file mode 100644
index 000000000..47e351f9d
--- /dev/null
+++ b/crates/syntax/Cargo.toml
@@ -0,0 +1,35 @@
1[package]
2name = "syntax"
3version = "0.0.0"
4description = "Comment and whitespace preserving parser for the Rust language"
5license = "MIT OR Apache-2.0"
6repository = "https://github.com/rust-analyzer/rust-analyzer"
7authors = ["rust-analyzer developers"]
8edition = "2018"
9
10[lib]
11doctest = false
12
13[dependencies]
14itertools = "0.9.0"
15rowan = "0.10.0"
16rustc_lexer = { version = "671.0.0", package = "rustc-ap-rustc_lexer" }
17rustc-hash = "1.1.0"
18arrayvec = "0.5.1"
19once_cell = "1.3.1"
20# This crate transitively depends on `smol_str` via `rowan`.
21# ideally, `serde` should be enabled by `rust-analyzer`, but we enable it here
22# to reduce number of compilations
23smol_str = { version = "0.1.15", features = ["serde"] }
24serde = { version = "1.0.106", features = ["derive"] }
25
26stdx = { path = "../stdx" }
27text_edit = { path = "../text_edit" }
28parser = { path = "../parser" }
29
30[dev-dependencies]
31walkdir = "2.3.1"
32rayon = "1"
33
34test_utils = { path = "../test_utils" }
35expect = { path = "../expect" }