aboutsummaryrefslogtreecommitdiff
path: root/crates/syntax/fuzz/Cargo.toml
diff options
context:
space:
mode:
authorAleksey Kladov <[email protected]>2020-08-12 17:26:51 +0100
committerAleksey Kladov <[email protected]>2020-08-12 17:30:53 +0100
commita1c187eef3ba08076aedb5154929f7eda8d1b424 (patch)
tree9d898eb9600b0c36a74e4f95238f679c683fa566 /crates/syntax/fuzz/Cargo.toml
parent3d6889cba72a9d02199f7adaa2ecc69bc30af834 (diff)
Rename ra_syntax -> syntax
Diffstat (limited to 'crates/syntax/fuzz/Cargo.toml')
-rw-r--r--crates/syntax/fuzz/Cargo.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/crates/syntax/fuzz/Cargo.toml b/crates/syntax/fuzz/Cargo.toml
new file mode 100644
index 000000000..32c40d1b9
--- /dev/null
+++ b/crates/syntax/fuzz/Cargo.toml
@@ -0,0 +1,27 @@
1
2[package]
3name = "syntax-fuzz"
4version = "0.0.1"
5authors = ["rust-analyzer developers"]
6publish = false
7edition = "2018"
8
9[package.metadata]
10cargo-fuzz = true
11
12[dependencies]
13syntax = { path = ".." }
14text_edit = { path = "../../text_edit" }
15libfuzzer-sys = { git = "https://github.com/rust-fuzz/libfuzzer-sys.git" }
16
17# Prevent this from interfering with workspaces
18[workspace]
19members = ["."]
20
21[[bin]]
22name = "parser"
23path = "fuzz_targets/parser.rs"
24
25[[bin]]
26name = "reparse"
27path = "fuzz_targets/reparse.rs"