aboutsummaryrefslogtreecommitdiff
path: root/crates/vfs-notify/Cargo.toml
diff options
context:
space:
mode:
authorbors[bot] <26634292+bors[bot]@users.noreply.github.com>2020-06-23 16:53:56 +0100
committerGitHub <[email protected]>2020-06-23 16:53:56 +0100
commit0c12c4f9609ee72487af9b55a558b01af73ffe3e (patch)
tree29be52a980b4cae72f46a48c48135a15e31641e0 /crates/vfs-notify/Cargo.toml
parent7aa66371ee3e8b31217513204c8b4f683584419d (diff)
parentdad1333b48c38bc7a5628fc0ff5304d003776a85 (diff)
Merge #4976
4976: New VFS r=matklad a=matklad Still a draft, but mostly working already. Co-authored-by: Aleksey Kladov <[email protected]>
Diffstat (limited to 'crates/vfs-notify/Cargo.toml')
-rw-r--r--crates/vfs-notify/Cargo.toml17
1 files changed, 17 insertions, 0 deletions
diff --git a/crates/vfs-notify/Cargo.toml b/crates/vfs-notify/Cargo.toml
new file mode 100644
index 000000000..4737a52a7
--- /dev/null
+++ b/crates/vfs-notify/Cargo.toml
@@ -0,0 +1,17 @@
1[package]
2name = "vfs-notify"
3version = "0.1.0"
4authors = ["rust-analyzer developers"]
5edition = "2018"
6
7[dependencies]
8log = "0.4.8"
9rustc-hash = "1.0"
10jod-thread = "0.1.0"
11walkdir = "2.3.1"
12globset = "0.4.5"
13crossbeam-channel = "0.4.0"
14notify = "5.0.0-pre.3"
15
16vfs = { path = "../vfs" }
17paths = { path = "../paths" }