aboutsummaryrefslogtreecommitdiff
path: root/xtask/Cargo.toml
diff options
context:
space:
mode:
authorbors[bot] <26634292+bors[bot]@users.noreply.github.com>2020-07-29 18:18:53 +0100
committerGitHub <[email protected]>2020-07-29 18:18:53 +0100
commit2dfda0b984c45946b9a4148bd848350deac544f2 (patch)
tree1942eeab995b0bd191c6a998b47cb20a426e5dd3 /xtask/Cargo.toml
parent525ae706b3e4c0f5f8b80d197e5fede0a9974442 (diff)
parent3d28292157e1b6c9675ef64eddf53786c3e7dc5f (diff)
Merge #5572
5572: Switch to ungrammar from ast_src r=matklad a=matklad The primary advantage of ungrammar is that it (eventually) allows one to describe concrete syntax tree structure -- with alternatives and specific sequence of tokens & nodes. That should be re-usable for: * generate `make` calls * Rust reference * Hypothetical parser's evented API We loose doc comments for the time being unfortunately. I don't think we should add support for doc comments to ungrammar -- they'll make grammar file hard to read. We might supply docs as out-of band info, or maybe just via a reference, but we'll think about that once things are no longer in flux bors r+ 🤖 Co-authored-by: Aleksey Kladov <[email protected]>
Diffstat (limited to 'xtask/Cargo.toml')
-rw-r--r--xtask/Cargo.toml9
1 files changed, 5 insertions, 4 deletions
diff --git a/xtask/Cargo.toml b/xtask/Cargo.toml
index d1cfb5909..8140da87f 100644
--- a/xtask/Cargo.toml
+++ b/xtask/Cargo.toml
@@ -10,9 +10,10 @@ license = "MIT OR Apache-2.0"
10doctest = false 10doctest = false
11 11
12[dependencies] 12[dependencies]
13walkdir = "2.3.1"
14pico-args = "0.3.1"
15quote = "1.0.2"
16proc-macro2 = "1.0.8"
17anyhow = "1.0.26" 13anyhow = "1.0.26"
18flate2 = "1.0" 14flate2 = "1.0"
15pico-args = "0.3.1"
16proc-macro2 = "1.0.8"
17quote = "1.0.2"
18ungrammar = "0.1.0"
19walkdir = "2.3.1"