aboutsummaryrefslogtreecommitdiff
path: root/crates/hir/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/hir/Cargo.toml')
-rw-r--r--crates/hir/Cargo.toml24
1 files changed, 24 insertions, 0 deletions
diff --git a/crates/hir/Cargo.toml b/crates/hir/Cargo.toml
new file mode 100644
index 000000000..dbb2986b6
--- /dev/null
+++ b/crates/hir/Cargo.toml
@@ -0,0 +1,24 @@
1[package]
2name = "hir"
3version = "0.0.0"
4license = "MIT OR Apache-2.0"
5authors = ["rust-analyzer developers"]
6edition = "2018"
7
8[lib]
9doctest = false
10
11[dependencies]
12log = "0.4.8"
13rustc-hash = "1.1.0"
14either = "1.5.3"
15arrayvec = "0.5.1"
16itertools = "0.9.0"
17
18stdx = { path = "../stdx" }
19syntax = { path = "../syntax" }
20base_db = { path = "../base_db" }
21profile = { path = "../profile" }
22hir_expand = { path = "../hir_expand" }
23hir_def = { path = "../hir_def" }
24hir_ty = { path = "../hir_ty" }