diff options
Diffstat (limited to 'crates/hir_def/Cargo.toml')
-rw-r--r-- | crates/hir_def/Cargo.toml | 35 |
1 files changed, 35 insertions, 0 deletions
diff --git a/crates/hir_def/Cargo.toml b/crates/hir_def/Cargo.toml new file mode 100644 index 000000000..57745322f --- /dev/null +++ b/crates/hir_def/Cargo.toml | |||
@@ -0,0 +1,35 @@ | |||
1 | [package] | ||
2 | name = "hir_def" | ||
3 | version = "0.0.0" | ||
4 | license = "MIT OR Apache-2.0" | ||
5 | authors = ["rust-analyzer developers"] | ||
6 | edition = "2018" | ||
7 | |||
8 | [lib] | ||
9 | doctest = false | ||
10 | |||
11 | [dependencies] | ||
12 | log = "0.4.8" | ||
13 | once_cell = "1.3.1" | ||
14 | rustc-hash = "1.1.0" | ||
15 | either = "1.5.3" | ||
16 | anymap = "0.12.1" | ||
17 | drop_bomb = "0.1.4" | ||
18 | fst = { version = "0.4", default-features = false } | ||
19 | itertools = "0.9.0" | ||
20 | indexmap = "1.4.0" | ||
21 | smallvec = "1.4.0" | ||
22 | |||
23 | stdx = { path = "../stdx" } | ||
24 | arena = { path = "../arena" } | ||
25 | base_db = { path = "../base_db" } | ||
26 | syntax = { path = "../syntax" } | ||
27 | profile = { path = "../profile" } | ||
28 | hir_expand = { path = "../hir_expand" } | ||
29 | test_utils = { path = "../test_utils" } | ||
30 | mbe = { path = "../mbe" } | ||
31 | cfg = { path = "../cfg" } | ||
32 | tt = { path = "../tt" } | ||
33 | |||
34 | [dev-dependencies] | ||
35 | expect-test = "0.1" | ||