diff options
Diffstat (limited to 'crates/ide/Cargo.toml')
-rw-r--r-- | crates/ide/Cargo.toml | 35 |
1 files changed, 35 insertions, 0 deletions
diff --git a/crates/ide/Cargo.toml b/crates/ide/Cargo.toml new file mode 100644 index 000000000..e4b970c73 --- /dev/null +++ b/crates/ide/Cargo.toml | |||
@@ -0,0 +1,35 @@ | |||
1 | [package] | ||
2 | name = "ide" | ||
3 | version = "0.0.0" | ||
4 | license = "MIT OR Apache-2.0" | ||
5 | authors = ["rust-analyzer developers"] | ||
6 | edition = "2018" | ||
7 | |||
8 | [lib] | ||
9 | doctest = false | ||
10 | |||
11 | [dependencies] | ||
12 | either = "1.5.3" | ||
13 | indexmap = "1.3.2" | ||
14 | itertools = "0.9.0" | ||
15 | log = "0.4.8" | ||
16 | rustc-hash = "1.1.0" | ||
17 | oorandom = "11.1.2" | ||
18 | |||
19 | stdx = { path = "../stdx" } | ||
20 | syntax = { path = "../syntax" } | ||
21 | text_edit = { path = "../text_edit" } | ||
22 | base_db = { path = "../base_db" } | ||
23 | ide_db = { path = "../ide_db" } | ||
24 | cfg = { path = "../cfg" } | ||
25 | profile = { path = "../profile" } | ||
26 | test_utils = { path = "../test_utils" } | ||
27 | assists = { path = "../assists" } | ||
28 | ssr = { path = "../ssr" } | ||
29 | |||
30 | # ide should depend only on the top-level `hir` package. if you need | ||
31 | # something from some `hir_xxx` subpackage, reexport the API via `hir`. | ||
32 | hir = { path = "../hir" } | ||
33 | |||
34 | [dev-dependencies] | ||
35 | expect = { path = "../expect" } | ||