aboutsummaryrefslogtreecommitdiff
path: root/crates/ide_db/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/ide_db/Cargo.toml')
-rw-r--r--crates/ide_db/Cargo.toml15
1 files changed, 8 insertions, 7 deletions
diff --git a/crates/ide_db/Cargo.toml b/crates/ide_db/Cargo.toml
index 692fb6415..320fb15e5 100644
--- a/crates/ide_db/Cargo.toml
+++ b/crates/ide_db/Cargo.toml
@@ -1,6 +1,7 @@
1[package] 1[package]
2name = "ide_db" 2name = "ide_db"
3version = "0.0.0" 3version = "0.0.0"
4description = "TBD"
4license = "MIT OR Apache-2.0" 5license = "MIT OR Apache-2.0"
5authors = ["rust-analyzer developers"] 6authors = ["rust-analyzer developers"]
6edition = "2018" 7edition = "2018"
@@ -19,12 +20,12 @@ rustc-hash = "1.1.0"
19once_cell = "1.3.1" 20once_cell = "1.3.1"
20either = "1.5.3" 21either = "1.5.3"
21 22
22stdx = { path = "../stdx" } 23stdx = { path = "../stdx", version = "0.0.0" }
23syntax = { path = "../syntax" } 24syntax = { path = "../syntax", version = "0.0.0" }
24text_edit = { path = "../text_edit" } 25text_edit = { path = "../text_edit", version = "0.0.0" }
25base_db = { path = "../base_db" } 26base_db = { path = "../base_db", version = "0.0.0" }
26profile = { path = "../profile" } 27profile = { path = "../profile", version = "0.0.0" }
27test_utils = { path = "../test_utils" } 28test_utils = { path = "../test_utils", version = "0.0.0" }
28# ide should depend only on the top-level `hir` package. if you need 29# ide should depend only on the top-level `hir` package. if you need
29# something from some `hir_xxx` subpackage, reexport the API via `hir`. 30# something from some `hir_xxx` subpackage, reexport the API via `hir`.
30hir = { path = "../hir" } 31hir = { path = "../hir", version = "0.0.0" }