aboutsummaryrefslogtreecommitdiff
path: root/crates/ide_db/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/ide_db/Cargo.toml')
-rw-r--r--crates/ide_db/Cargo.toml30
1 files changed, 30 insertions, 0 deletions
diff --git a/crates/ide_db/Cargo.toml b/crates/ide_db/Cargo.toml
new file mode 100644
index 000000000..885212162
--- /dev/null
+++ b/crates/ide_db/Cargo.toml
@@ -0,0 +1,30 @@
1[package]
2name = "ide_db"
3version = "0.0.0"
4license = "MIT OR Apache-2.0"
5authors = ["rust-analyzer developers"]
6edition = "2018"
7
8[lib]
9doctest = false
10
11[features]
12wasm = []
13
14[dependencies]
15log = "0.4.8"
16rayon = "1.3.0"
17fst = { version = "0.4", default-features = false }
18rustc-hash = "1.1.0"
19once_cell = "1.3.1"
20either = "1.5.3"
21
22stdx = { path = "../stdx" }
23syntax = { path = "../syntax" }
24text_edit = { path = "../text_edit" }
25base_db = { path = "../base_db" }
26profile = { path = "../profile" }
27test_utils = { path = "../test_utils" }
28# ra_ide should depend only on the top-level `hir` package. if you need
29# something from some `hir_xxx` subpackage, reexport the API via `hir`.
30hir = { path = "../hir" }