diff options
Diffstat (limited to 'crates/ide_db/Cargo.toml')
-rw-r--r-- | crates/ide_db/Cargo.toml | 30 |
1 files changed, 30 insertions, 0 deletions
diff --git a/crates/ide_db/Cargo.toml b/crates/ide_db/Cargo.toml new file mode 100644 index 000000000..692fb6415 --- /dev/null +++ b/crates/ide_db/Cargo.toml | |||
@@ -0,0 +1,30 @@ | |||
1 | [package] | ||
2 | name = "ide_db" | ||
3 | version = "0.0.0" | ||
4 | license = "MIT OR Apache-2.0" | ||
5 | authors = ["rust-analyzer developers"] | ||
6 | edition = "2018" | ||
7 | |||
8 | [lib] | ||
9 | doctest = false | ||
10 | |||
11 | [features] | ||
12 | wasm = [] | ||
13 | |||
14 | [dependencies] | ||
15 | log = "0.4.8" | ||
16 | rayon = "1.3.0" | ||
17 | fst = { version = "0.4", default-features = false } | ||
18 | rustc-hash = "1.1.0" | ||
19 | once_cell = "1.3.1" | ||
20 | either = "1.5.3" | ||
21 | |||
22 | stdx = { path = "../stdx" } | ||
23 | syntax = { path = "../syntax" } | ||
24 | text_edit = { path = "../text_edit" } | ||
25 | base_db = { path = "../base_db" } | ||
26 | profile = { path = "../profile" } | ||
27 | test_utils = { path = "../test_utils" } | ||
28 | # ide should depend only on the top-level `hir` package. if you need | ||
29 | # something from some `hir_xxx` subpackage, reexport the API via `hir`. | ||
30 | hir = { path = "../hir" } | ||