aboutsummaryrefslogtreecommitdiff
path: root/crates/ide_ssr/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/ide_ssr/Cargo.toml')
-rw-r--r--crates/ide_ssr/Cargo.toml24
1 files changed, 24 insertions, 0 deletions
diff --git a/crates/ide_ssr/Cargo.toml b/crates/ide_ssr/Cargo.toml
new file mode 100644
index 000000000..edbc1846b
--- /dev/null
+++ b/crates/ide_ssr/Cargo.toml
@@ -0,0 +1,24 @@
1[package]
2name = "ide_ssr"
3version = "0.0.0"
4description = "Structural search and replace of Rust code"
5license = "MIT OR Apache-2.0"
6repository = "https://github.com/rust-analyzer/rust-analyzer"
7authors = ["rust-analyzer developers"]
8edition = "2018"
9
10[lib]
11doctest = false
12
13[dependencies]
14rustc-hash = "1.1.0"
15itertools = "0.10.0"
16
17text_edit = { path = "../text_edit", version = "0.0.0" }
18syntax = { path = "../syntax", version = "0.0.0" }
19ide_db = { path = "../ide_db", version = "0.0.0" }
20hir = { path = "../hir", version = "0.0.0" }
21test_utils = { path = "../test_utils", version = "0.0.0" }
22
23[dev-dependencies]
24expect-test = "1.1"