aboutsummaryrefslogtreecommitdiff
path: root/crates/proc_macro_srv/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/proc_macro_srv/Cargo.toml')
-rw-r--r--crates/proc_macro_srv/Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/crates/proc_macro_srv/Cargo.toml b/crates/proc_macro_srv/Cargo.toml
new file mode 100644
index 000000000..775af890e
--- /dev/null
+++ b/crates/proc_macro_srv/Cargo.toml
@@ -0,0 +1,25 @@
1[package]
2name = "proc_macro_srv"
3version = "0.0.0"
4license = "MIT OR Apache-2.0"
5authors = ["rust-analyzer developers"]
6edition = "2018"
7
8[lib]
9doctest = false
10
11[dependencies]
12tt = { path = "../tt" }
13ra_mbe = { path = "../ra_mbe" }
14ra_proc_macro = { path = "../ra_proc_macro" }
15goblin = "0.2.1"
16libloading = "0.6.0"
17memmap = "0.7"
18test_utils = { path = "../test_utils" }
19
20[dev-dependencies]
21cargo_metadata = "0.11.1"
22difference = "2.0.0"
23# used as proc macro test target
24serde_derive = "1.0.106"
25toolchain = { path = "../toolchain" }