aboutsummaryrefslogtreecommitdiff
path: root/crates/profile/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/profile/Cargo.toml')
-rw-r--r--crates/profile/Cargo.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/crates/profile/Cargo.toml b/crates/profile/Cargo.toml
new file mode 100644
index 000000000..e271e3a56
--- /dev/null
+++ b/crates/profile/Cargo.toml
@@ -0,0 +1,27 @@
1[package]
2name = "profile"
3version = "0.0.0"
4license = "MIT OR Apache-2.0"
5authors = ["rust-analyzer developers"]
6edition = "2018"
7
8[lib]
9doctest = false
10
11[dependencies]
12once_cell = "1.3.1"
13cfg-if = "0.1.10"
14libc = "0.2.73"
15backtrace = { version = "0.3.44", optional = true }
16
17arena = { path = "../arena" }
18
19[target.'cfg(target_os = "linux")'.dependencies]
20perf-event = "0.4"
21
22[features]
23cpu_profiler = []
24
25# Uncomment to enable for the whole crate graph
26# default = [ "backtrace" ]
27# default = [ "cpu_profiler" ]