diff options
Diffstat (limited to 'crates/profile/Cargo.toml')
-rw-r--r-- | crates/profile/Cargo.toml | 27 |
1 files changed, 27 insertions, 0 deletions
diff --git a/crates/profile/Cargo.toml b/crates/profile/Cargo.toml new file mode 100644 index 000000000..e271e3a56 --- /dev/null +++ b/crates/profile/Cargo.toml | |||
@@ -0,0 +1,27 @@ | |||
1 | [package] | ||
2 | name = "profile" | ||
3 | version = "0.0.0" | ||
4 | license = "MIT OR Apache-2.0" | ||
5 | authors = ["rust-analyzer developers"] | ||
6 | edition = "2018" | ||
7 | |||
8 | [lib] | ||
9 | doctest = false | ||
10 | |||
11 | [dependencies] | ||
12 | once_cell = "1.3.1" | ||
13 | cfg-if = "0.1.10" | ||
14 | libc = "0.2.73" | ||
15 | backtrace = { version = "0.3.44", optional = true } | ||
16 | |||
17 | arena = { path = "../arena" } | ||
18 | |||
19 | [target.'cfg(target_os = "linux")'.dependencies] | ||
20 | perf-event = "0.4" | ||
21 | |||
22 | [features] | ||
23 | cpu_profiler = [] | ||
24 | |||
25 | # Uncomment to enable for the whole crate graph | ||
26 | # default = [ "backtrace" ] | ||
27 | # default = [ "cpu_profiler" ] | ||