aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_cli/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/ra_cli/Cargo.toml')
-rw-r--r--crates/ra_cli/Cargo.toml15
1 files changed, 10 insertions, 5 deletions
diff --git a/crates/ra_cli/Cargo.toml b/crates/ra_cli/Cargo.toml
index 53d4876f6..03494a809 100644
--- a/crates/ra_cli/Cargo.toml
+++ b/crates/ra_cli/Cargo.toml
@@ -6,18 +6,23 @@ authors = ["rust-analyzer developers"]
6publish = false 6publish = false
7 7
8[dependencies] 8[dependencies]
9crossbeam-channel = "0.4.0"
10env_logger = { version = "0.7.1", default-features = false }
9itertools = "0.8.0" 11itertools = "0.8.0"
12log = "0.4.5"
10pico-args = "0.3.0" 13pico-args = "0.3.0"
11env_logger = { version = "0.7.1", default-features = false }
12rand = { version = "0.7.0", features = ["small_rng"] } 14rand = { version = "0.7.0", features = ["small_rng"] }
15rustc-hash = "1.0"
13 16
14ra_syntax = { path = "../ra_syntax" }
15ra_ide = { path = "../ra_ide" }
16ra_batch = { path = "../ra_batch" }
17hir = { path = "../ra_hir", package = "ra_hir" } 17hir = { path = "../ra_hir", package = "ra_hir" }
18hir_ty = { path = "../ra_hir_ty", package = "ra_hir_ty" }
19hir_def = { path = "../ra_hir_def", package = "ra_hir_def" } 18hir_def = { path = "../ra_hir_def", package = "ra_hir_def" }
19hir_ty = { path = "../ra_hir_ty", package = "ra_hir_ty" }
20ra_db = { path = "../ra_db" } 20ra_db = { path = "../ra_db" }
21ra_ide = { path = "../ra_ide" }
22ra_project_model = { path = "../ra_project_model" }
23ra_syntax = { path = "../ra_syntax" }
24ra_vfs = "0.5.0"
25ra_vfs_glob = { path = "../ra_vfs_glob" }
21 26
22[dependencies.ra_prof] 27[dependencies.ra_prof]
23path = "../ra_prof" 28path = "../ra_prof"