aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_ide/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/ra_ide/Cargo.toml')
-rw-r--r--crates/ra_ide/Cargo.toml20
1 files changed, 12 insertions, 8 deletions
diff --git a/crates/ra_ide/Cargo.toml b/crates/ra_ide/Cargo.toml
index 97dea5ffd..3407d2598 100644
--- a/crates/ra_ide/Cargo.toml
+++ b/crates/ra_ide/Cargo.toml
@@ -11,15 +11,19 @@ doctest = false
11wasm = [] 11wasm = []
12 12
13[dependencies] 13[dependencies]
14either = "1.5" 14either = "1.5.3"
15format-buf = "1.0.0" 15format-buf = "1.0.0"
16indexmap = "1.3.0" 16indexmap = "1.3.2"
17itertools = "0.8.0" 17itertools = "0.8.2"
18join_to_string = "0.1.3" 18join_to_string = "0.1.3"
19log = "0.4.5" 19log = "0.4.8"
20rustc-hash = "1.0" 20rayon = "1.3.0"
21rand = { version = "0.7.0", features = ["small_rng"] } 21fst = { version = "0.3.5", default-features = false }
22once_cell = "1.2.0" 22rustc-hash = "1.1.0"
23unicase = "2.6.0"
24superslice = "1.0.0"
25rand = { version = "0.7.3", features = ["small_rng"] }
26once_cell = "1.3.1"
23 27
24ra_syntax = { path = "../ra_syntax" } 28ra_syntax = { path = "../ra_syntax" }
25ra_text_edit = { path = "../ra_text_edit" } 29ra_text_edit = { path = "../ra_text_edit" }
@@ -36,4 +40,4 @@ ra_assists = { path = "../ra_assists" }
36hir = { path = "../ra_hir", package = "ra_hir" } 40hir = { path = "../ra_hir", package = "ra_hir" }
37 41
38[dev-dependencies] 42[dev-dependencies]
39insta = "0.13.0" 43insta = "0.13.1"