aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_ide_api/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/ra_ide_api/Cargo.toml')
-rw-r--r--crates/ra_ide_api/Cargo.toml6
1 files changed, 0 insertions, 6 deletions
diff --git a/crates/ra_ide_api/Cargo.toml b/crates/ra_ide_api/Cargo.toml
index 9bf5dd6e6..5bd768817 100644
--- a/crates/ra_ide_api/Cargo.toml
+++ b/crates/ra_ide_api/Cargo.toml
@@ -16,9 +16,6 @@ unicase = "2.2.0"
16superslice = "1.0.0" 16superslice = "1.0.0"
17rand = "0.6.5" 17rand = "0.6.5"
18 18
19jemallocator = { version = "0.1.9", optional = true }
20jemalloc-ctl = { version = "0.2.0", optional = true }
21
22ra_syntax = { path = "../ra_syntax" } 19ra_syntax = { path = "../ra_syntax" }
23ra_text_edit = { path = "../ra_text_edit" } 20ra_text_edit = { path = "../ra_text_edit" }
24ra_db = { path = "../ra_db" } 21ra_db = { path = "../ra_db" }
@@ -36,6 +33,3 @@ version = "0.9.0"
36# Disable `fork` feature to allow compiling on webassembly 33# Disable `fork` feature to allow compiling on webassembly
37default-features = false 34default-features = false
38features = ["std", "bit-set", "break-dead-code"] 35features = ["std", "bit-set", "break-dead-code"]
39
40[features]
41jemalloc = [ "jemallocator", "jemalloc-ctl" ]