aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_ide_api/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/ra_ide_api/Cargo.toml')
-rw-r--r--crates/ra_ide_api/Cargo.toml23
1 files changed, 23 insertions, 0 deletions
diff --git a/crates/ra_ide_api/Cargo.toml b/crates/ra_ide_api/Cargo.toml
new file mode 100644
index 000000000..d42a664b6
--- /dev/null
+++ b/crates/ra_ide_api/Cargo.toml
@@ -0,0 +1,23 @@
1[package]
2edition = "2018"
3name = "ra_ide_api"
4version = "0.1.0"
5authors = ["Aleksey Kladov <[email protected]>"]
6
7[dependencies]
8itertools = "0.8.0"
9log = "0.4.5"
10relative-path = "0.4.0"
11rayon = "1.0.2"
12fst = "0.3.1"
13salsa = "0.9.1"
14rustc-hash = "1.0"
15parking_lot = "0.7.0"
16unicase = "2.2.0"
17
18ra_syntax = { path = "../ra_syntax" }
19ra_ide_api_light = { path = "../ra_ide_api_light" }
20ra_text_edit = { path = "../ra_text_edit" }
21ra_db = { path = "../ra_db" }
22hir = { path = "../ra_hir", package = "ra_hir" }
23test_utils = { path = "../test_utils" }