aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_ide_db/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/ra_ide_db/Cargo.toml')
-rw-r--r--crates/ra_ide_db/Cargo.toml47
1 files changed, 47 insertions, 0 deletions
diff --git a/crates/ra_ide_db/Cargo.toml b/crates/ra_ide_db/Cargo.toml
new file mode 100644
index 000000000..716e88bc1
--- /dev/null
+++ b/crates/ra_ide_db/Cargo.toml
@@ -0,0 +1,47 @@
1[package]
2edition = "2018"
3name = "ra_ide_db"
4version = "0.1.0"
5authors = ["rust-analyzer developers"]
6
7[lib]
8doctest = false
9
10[features]
11wasm = []
12
13[dependencies]
14either = "1.5"
15format-buf = "1.0.0"
16indexmap = "1.3.0"
17itertools = "0.8.0"
18join_to_string = "0.1.3"
19log = "0.4.5"
20rayon = "1.0.2"
21fst = { version = "0.3.1", default-features = false }
22rustc-hash = "1.0"
23unicase = "2.2.0"
24superslice = "1.0.0"
25rand = { version = "0.7.0", features = ["small_rng"] }
26once_cell = "1.2.0"
27
28ra_syntax = { path = "../ra_syntax" }
29ra_text_edit = { path = "../ra_text_edit" }
30ra_db = { path = "../ra_db" }
31ra_cfg = { path = "../ra_cfg" }
32ra_fmt = { path = "../ra_fmt" }
33ra_prof = { path = "../ra_prof" }
34test_utils = { path = "../test_utils" }
35
36# ra_ide should depend only on the top-level `hir` package. if you need
37# something from some `hir_xxx` subpackage, reexport the API via `hir`.
38hir = { path = "../ra_hir", package = "ra_hir" }
39
40[dev-dependencies]
41insta = "0.13.0"
42
43[dev-dependencies.proptest]
44version = "0.9.0"
45# Disable `fork` feature to allow compiling on webassembly
46default-features = false
47features = ["std", "bit-set", "break-dead-code"]