aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_prof/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/ra_prof/Cargo.toml')
-rw-r--r--crates/ra_prof/Cargo.toml36
1 files changed, 19 insertions, 17 deletions
diff --git a/crates/ra_prof/Cargo.toml b/crates/ra_prof/Cargo.toml
index 7db4498c3..bb241258c 100644
--- a/crates/ra_prof/Cargo.toml
+++ b/crates/ra_prof/Cargo.toml
@@ -1,17 +1,19 @@
1[package] 1[package]
2edition = "2018" 2edition = "2018"
3name = "ra_prof" 3name = "ra_prof"
4version = "0.1.0" 4version = "0.1.0"
5authors = ["rust-analyzer developers"] 5authors = ["rust-analyzer developers"]
6publish = false 6publish = false
7 7
8[dependencies] 8[dependencies]
9once_cell = "1.0.1" 9once_cell = "1.0.1"
10itertools = "0.8.0" 10itertools = "0.8.0"
11backtrace = "0.3.28" 11backtrace = "0.3.28"
12jemallocator = { version = "0.3.2", optional = true } 12
13jemalloc-ctl = { version = "0.3.2", optional = true } 13[target.'cfg(not(target_env = "msvc"))'.dependencies]
14 14jemallocator = { version = "0.3.2", optional = true }
15[features] 15jemalloc-ctl = { version = "0.3.2", optional = true }
16jemalloc = [ "jemallocator", "jemalloc-ctl" ] 16
17cpu_profiler = [] 17[features]
18jemalloc = [ "jemallocator", "jemalloc-ctl" ]
19cpu_profiler = []