aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_prof/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/ra_prof/Cargo.toml')
-rw-r--r--crates/ra_prof/Cargo.toml6
1 files changed, 0 insertions, 6 deletions
diff --git a/crates/ra_prof/Cargo.toml b/crates/ra_prof/Cargo.toml
index 2e60858f1..84d895317 100644
--- a/crates/ra_prof/Cargo.toml
+++ b/crates/ra_prof/Cargo.toml
@@ -17,16 +17,10 @@ mimalloc = { version = "0.1.19", default-features = false, optional = true }
17cfg-if = "0.1.10" 17cfg-if = "0.1.10"
18libc = "0.2.73" 18libc = "0.2.73"
19 19
20[target.'cfg(not(target_env = "msvc"))'.dependencies]
21jemallocator = { version = "0.3.2", optional = true }
22jemalloc-ctl = { version = "0.3.3", optional = true }
23
24[features] 20[features]
25jemalloc = [ "jemallocator", "jemalloc-ctl" ]
26cpu_profiler = [] 21cpu_profiler = []
27 22
28# Uncomment to enable for the whole crate graph 23# Uncomment to enable for the whole crate graph
29# default = [ "backtrace" ] 24# default = [ "backtrace" ]
30# default = [ "jemalloc" ]
31# default = [ "mimalloc" ] 25# default = [ "mimalloc" ]
32# default = [ "cpu_profiler" ] 26# default = [ "cpu_profiler" ]