aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_prof/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/ra_prof/Cargo.toml')
-rw-r--r--crates/ra_prof/Cargo.toml13
1 files changed, 9 insertions, 4 deletions
diff --git a/crates/ra_prof/Cargo.toml b/crates/ra_prof/Cargo.toml
index c33b5121a..c82b9f76d 100644
--- a/crates/ra_prof/Cargo.toml
+++ b/crates/ra_prof/Cargo.toml
@@ -4,6 +4,7 @@ name = "ra_prof"
4version = "0.1.0" 4version = "0.1.0"
5authors = ["rust-analyzer developers"] 5authors = ["rust-analyzer developers"]
6publish = false 6publish = false
7license = "MIT OR Apache-2.0"
7 8
8[lib] 9[lib]
9doctest = false 10doctest = false
@@ -12,11 +13,15 @@ doctest = false
12ra_arena = { path = "../ra_arena" } 13ra_arena = { path = "../ra_arena" }
13once_cell = "1.3.1" 14once_cell = "1.3.1"
14backtrace = { version = "0.3.44", optional = true } 15backtrace = { version = "0.3.44", optional = true }
16cfg-if = "0.1.10"
17libc = "0.2.73"
15 18
16[target.'cfg(not(target_env = "msvc"))'.dependencies] 19[target.'cfg(target_os = "linux")'.dependencies]
17jemallocator = { version = "0.3.2", optional = true } 20perf-event = "0.4"
18jemalloc-ctl = { version = "0.3.3", optional = true }
19 21
20[features] 22[features]
21jemalloc = [ "jemallocator", "jemalloc-ctl" ]
22cpu_profiler = [] 23cpu_profiler = []
24
25# Uncomment to enable for the whole crate graph
26# default = [ "backtrace" ]
27# default = [ "cpu_profiler" ]