aboutsummaryrefslogtreecommitdiff
path: root/crates/ssr/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/ssr/Cargo.toml')
-rw-r--r--crates/ssr/Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/crates/ssr/Cargo.toml b/crates/ssr/Cargo.toml
new file mode 100644
index 000000000..22b6af0fa
--- /dev/null
+++ b/crates/ssr/Cargo.toml
@@ -0,0 +1,25 @@
1[package]
2name = "ssr"
3version = "0.0.0"
4description = "Structural search and replace of Rust code"
5license = "MIT OR Apache-2.0"
6repository = "https://github.com/rust-analyzer/rust-analyzer"
7authors = ["rust-analyzer developers"]
8edition = "2018"
9
10[lib]
11doctest = false
12
13[dependencies]
14rustc-hash = "1.1.0"
15itertools = "0.9.0"
16
17text_edit = { path = "../text_edit" }
18syntax = { path = "../syntax" }
19base_db = { path = "../base_db" }
20ide_db = { path = "../ide_db" }
21hir = { path = "../hir" }
22test_utils = { path = "../test_utils" }
23
24[dev-dependencies]
25expect-test = "0.1"