aboutsummaryrefslogtreecommitdiff
path: root/crates/ssr/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/ssr/Cargo.toml')
-rw-r--r--crates/ssr/Cargo.toml24
1 files changed, 24 insertions, 0 deletions
diff --git a/crates/ssr/Cargo.toml b/crates/ssr/Cargo.toml
new file mode 100644
index 000000000..cd05eeecc
--- /dev/null
+++ b/crates/ssr/Cargo.toml
@@ -0,0 +1,24 @@
1[package]
2name = "ssr"
3version = "0.1.0"
4description = "Structural search and replace of Rust code"
5license = "MIT OR Apache-2.0"
6repository = "https://github.com/rust-analyzer/rust-analyzer"
7authors = ["rust-analyzer developers"]
8edition = "2018"
9
10[lib]
11doctest = false
12
13[dependencies]
14rustc-hash = "1.1.0"
15
16text_edit = { path = "../text_edit" }
17syntax = { path = "../syntax" }
18base_db = { path = "../base_db" }
19ide_db = { path = "../ide_db" }
20hir = { path = "../hir" }
21test_utils = { path = "../test_utils" }
22
23[dev-dependencies]
24expect = { path = "../expect" }