aboutsummaryrefslogtreecommitdiff
path: root/bin/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'bin/Cargo.toml')
-rw-r--r--bin/Cargo.toml12
1 files changed, 11 insertions, 1 deletions
diff --git a/bin/Cargo.toml b/bin/Cargo.toml
index d67e6c1..7c48083 100644
--- a/bin/Cargo.toml
+++ b/bin/Cargo.toml
@@ -6,7 +6,13 @@ license = "MIT"
6authors = [ "Akshay <[email protected]>" ] 6authors = [ "Akshay <[email protected]>" ]
7description = "Lints and suggestions for the Nix programming language" 7description = "Lints and suggestions for the Nix programming language"
8 8
9# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html 9[lib]
10name = "statix"
11path = "src/lib.rs"
12
13[[bin]]
14name = "statix"
15path = "src/main.rs"
10 16
11[dependencies] 17[dependencies]
12ariadne = "0.1.3" 18ariadne = "0.1.3"
@@ -27,5 +33,9 @@ version = "1.0.68"
27features = [ "derive" ] 33features = [ "derive" ]
28optional = true 34optional = true
29 35
36[dev-dependencies]
37insta = "1.8.0"
38strip-ansi-escapes = "0.1.1"
39
30[features] 40[features]
31json = [ "lib/json-out", "serde_json", "serde" ] 41json = [ "lib/json-out", "serde_json", "serde" ]