aboutsummaryrefslogtreecommitdiff
path: root/bin/tests/data/unquoted_splices.nix
diff options
context:
space:
mode:
Diffstat (limited to 'bin/tests/data/unquoted_splices.nix')
-rw-r--r--bin/tests/data/unquoted_splices.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/bin/tests/data/unquoted_splices.nix b/bin/tests/data/unquoted_splices.nix
new file mode 100644
index 0000000..30935b0
--- /dev/null
+++ b/bin/tests/data/unquoted_splices.nix
@@ -0,0 +1,15 @@
1let
2 x = 2;
3 y = 3;
4 a = { "2" = y; };
5in
6[
7 ${x}
8 ${toString (x + y)}
9 a.${toString x}
10
11 # multiline test
12 ${
13 toString x
14 }
15]