aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml16
1 files changed, 15 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 147096b..570ec22 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,6 +11,20 @@ regex = "1.3"
11thiserror = "1.0.61" 11thiserror = "1.0.61"
12serde = "1.0.204" 12serde = "1.0.204"
13nom = "7.1.3" 13nom = "7.1.3"
14tree-sitter-python = "0.20" 14
15tree-sitter-md = {version = "0.1", optional = true}
16tree-sitter-typescript = {version = "0.20.1", optional = true}
17tree-sitter-javascript = {version = "0.20.0", optional = true}
18tree-sitter-python = {version = "0.20.4", optional = true}
19tree-sitter-rust = {version = "0.20.3", optional = true}
20argh = "0.1.12"
21
22[features]
23default = ["md", "typescript", "javascript", "rust", "python"]
24md = ["tree-sitter-md"]
25typescript = ["tree-sitter-typescript"]
26javascript = ["tree-sitter-javascript"]
27python = ["tree-sitter-python"]
28rust = ["tree-sitter-rust"]
15 29
16[dev-dependencies] 30[dev-dependencies]