aboutsummaryrefslogtreecommitdiff
path: root/backend/Cargo.toml
diff options
context:
space:
mode:
authorAkshay <[email protected]>2020-12-24 05:21:40 +0000
committerAkshay <[email protected]>2020-12-24 05:21:40 +0000
commit9d2b6ee10ec5359cc91769d430485c8c869ba1a8 (patch)
treeb2d541e575ab6e3f70cb709f156f06afca085881 /backend/Cargo.toml
parent7c65421328552b08e64df25e224fe9d54d363e6e (diff)
monorepo
Diffstat (limited to 'backend/Cargo.toml')
-rw-r--r--backend/Cargo.toml29
1 files changed, 29 insertions, 0 deletions
diff --git a/backend/Cargo.toml b/backend/Cargo.toml
new file mode 100644
index 0000000..8ce728b
--- /dev/null
+++ b/backend/Cargo.toml
@@ -0,0 +1,29 @@
1[package]
2name = "furby"
3version = "0.1.0"
4authors = ["Akshay <[email protected]>"]
5edition = "2018"
6
7# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
8
9[dependencies]
10actix-web = "3"
11bcrypt = "0.8"
12serde = "1.0"
13serde_derive = "1.0"
14serde_json = "1.0"
15log = "0.4"
16pretty_env_logger = "0.4"
17actix-identity = "0.3.1"
18actix-cors = "0.5"
19bigdecimal = "0.0.14"
20rand = "0.7"
21
22[dependencies.diesel]
23version = "1.4.2"
24features = ["mysql", "r2d2", "numeric", "chrono"]
25default-features = false
26
27[dependencies.chrono]
28version = "0.4"
29features = ["serde"]