aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..5779d87
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,31 @@
1{ pkgs ? import <nixpkgs> {} }:
2
3let
4 sources = import ./nix/sources.nix;
5 nixpkgs-mozilla = import sources.nixpkgs-mozilla;
6 pkgs = import sources.nixpkgs {
7 overlays =
8 [
9 nixpkgs-mozilla
10 (self: super:
11 {
12 rustc = self.latest.rustChannels.nightly.rust;
13 cargo = self.latest.rustChannels.nightly.rust;
14 }
15 )
16 ];
17 };
18in
19 pkgs.mkShell {
20 buildInputs = with pkgs; [
21 cargo
22 rustc
23 rustfmt
24 pkg-config
25 openssl
26 httpie
27 curl
28 diesel-cli
29 libmysqlclient
30 ];
31 }