aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix34
1 files changed, 0 insertions, 34 deletions
diff --git a/shell.nix b/shell.nix
deleted file mode 100644
index 9167821..0000000
--- a/shell.nix
+++ /dev/null
@@ -1,34 +0,0 @@
1{ pkgs ? import <nixpkgs> {} }:
2
3let
4 sources = import ./nix/sources.nix;
5 nixpkgs-mozilla = import sources.nixpkgs-mozilla;
6 pkgs = import sources.nixpkgs {
7 overlays =
8 [
9 nixpkgs-mozilla
10 (self: super:
11 {
12 rustc = self.latest.rustChannels.stable.rust;
13 cargo = self.latest.rustChannels.stable.rust;
14 }
15 )
16 ];
17 };
18in
19 pkgs.mkShell {
20 buildInputs = with pkgs; [
21 cargo
22 rustc
23 rustfmt
24 pkg-config
25 openssl
26 httpie
27 curl
28 diesel-cli
29 libmysqlclient
30 jq
31 python3
32 insomnia
33 ];
34 }