aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix5
1 files changed, 2 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index 3308ce1..e341db6 100644
--- a/flake.nix
+++ b/flake.nix
@@ -10,13 +10,12 @@
10 , nixpkgs 10 , nixpkgs
11 }: 11 }:
12 let 12 let
13 allPrograms = [ 1 2 ];
13 supportedSystems = [ "x86_64-linux" ]; 14 supportedSystems = [ "x86_64-linux" ];
14 forAllSystems = f: nixpkgs.lib.genAttrs supportedSystems (system: f system); 15 forAllSystems = f: nixpkgs.lib.genAttrs supportedSystems (system: f system);
15
16 nixpkgsFor = forAllSystems (system: 16 nixpkgsFor = forAllSystems (system:
17 import nixpkgs { inherit system; } 17 import nixpkgs { inherit system; }
18 ); 18 );
19
20 in 19 in
21 { 20 {
22 devShell = forAllSystems 21 devShell = forAllSystems
@@ -33,7 +32,7 @@
33 (system: 32 (system:
34 let 33 let
35 pkgs = nixpkgsFor."${system}"; 34 pkgs = nixpkgsFor."${system}";
36 execs = with builtins; map toString [ 1 2 ]; 35 execs = with builtins; map toString allPrograms;
37 mkApp = name: with pkgs; stdenv.mkDerivation { 36 mkApp = name: with pkgs; stdenv.mkDerivation {
38 name = "${name}"; 37 name = "${name}";
39 src = ./src; 38 src = ./src;