aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..52603a1
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,25 @@
1[package]
2name = "cstea"
3version = "0.1.0"
4authors = ["Akshay <[email protected]>"]
5edition = "2018"
6
7[lib]
8crate-type = ["cdylib", "rlib"]
9
10[features]
11default = ["console_error_panic_hook"]
12
13[dependencies]
14wasm-bindgen = "0.2.63"
15syntax = { path = "../ref/ra-orig/crates/syntax" }
16console_error_panic_hook = { version = "0.1.6", optional = true }
17wee_alloc = { version = "0.4.5", optional = true }
18js-sys = "0.3.51"
19
20[dev-dependencies]
21wasm-bindgen-test = "0.3.13"
22
23[profile.release]
24# Tell `rustc` to optimize for small code size.
25opt-level = "s"