aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorAkshay <[email protected]>2020-08-22 16:46:26 +0100
committerAkshay <[email protected]>2020-08-22 16:46:26 +0100
commit70eeba1f481d625db311ea4d961453d3e1b90ea7 (patch)
treeded265527d9d9d1c9978b69bfd7b84a7717f807f /shell.nix
parent9e684bc6100b5db438108f78eea1c11155a47092 (diff)
init
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..580f53e
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,15 @@
1{
2 nixpkgs ? ./nix/nixpkgs.nix
3 , pkgs ? import nixpkgs
4}:
5
6pkgs.mkShell {
7 buildInputs = [
8 pkgs.cargo
9 pkgs.rustc
10 pkgs.git
11 pkgs.shellcheck
12 pkgs.sqlite
13 pkgs.httpie
14 ];
15}