aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorAkshay <[email protected]>2020-09-01 08:20:05 +0100
committerAkshay <[email protected]>2020-09-01 08:20:05 +0100
commit897df34e5e55448ae89fbf1a77533e792e7a5c4e (patch)
tree6821b0ffba5fe3f8910f4e2f55f2679d60ebf27f /shell.nix
parentc9c8db0f308eb5dcb552d15ecfd403d623dc40de (diff)
add dev shell
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..a74f68c
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,10 @@
1{ pkgs ? import <nixpkgs> {} }:
2
3with pkgs;
4mkShell {
5 buildInputs = [ miniserve ];
6 shellHook = ''
7 source ~/.bash_prompt
8 export PS1="$PS1(site) "
9 '';
10}