diff options
author | Akshay <[email protected]> | 2024-07-14 19:31:42 +0100 |
---|---|---|
committer | Akshay <[email protected]> | 2024-07-14 19:31:42 +0100 |
commit | 80ac5c569114e9f99a37119d97a6050b438f573a (patch) | |
tree | 9b389374e53ce304f31df44b2ebbd2eeb6b363b8 /Cargo.toml |
init
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 25 |
1 files changed, 25 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml new file mode 100644 index 0000000..73ec928 --- /dev/null +++ b/Cargo.toml | |||
@@ -0,0 +1,25 @@ | |||
1 | [package] | ||
2 | name = "tree-viz" | ||
3 | version = "0.1.0" | ||
4 | edition = "2021" | ||
5 | |||
6 | # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html | ||
7 | |||
8 | [dependencies] | ||
9 | tree-sitter-elm = "5.6.3" | ||
10 | tree-sitter-ruby = "0.21" | ||
11 | tree-sitter-rust = "0.21" | ||
12 | tree-sitter = "0.21" | ||
13 | console = "^0.15" | ||
14 | tree-sitter-go = "0.19.1" | ||
15 | tree-sitter-typescript = "0.21" | ||
16 | tree-sitter-javascript = "0.21" | ||
17 | tree-sitter-mdx = { git = "https://github.com/jlopezcur/tree-sitter-mdx" } | ||
18 | tree-sitter-json = { git = "https://github.com/tree-sitter/tree-sitter-json" } | ||
19 | tree-sitter-python = "0.21" | ||
20 | tree-sitter-md = "0.2.3" | ||
21 | # tree-sitter-cobol = { path = "../../tree-sitter-cobol/" } | ||
22 | |||
23 | [dependencies.notify] | ||
24 | version = "5.0.0" | ||
25 | default-features = false | ||