aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..73ec928
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,25 @@
1[package]
2name = "tree-viz"
3version = "0.1.0"
4edition = "2021"
5
6# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
7
8[dependencies]
9tree-sitter-elm = "5.6.3"
10tree-sitter-ruby = "0.21"
11tree-sitter-rust = "0.21"
12tree-sitter = "0.21"
13console = "^0.15"
14tree-sitter-go = "0.19.1"
15tree-sitter-typescript = "0.21"
16tree-sitter-javascript = "0.21"
17tree-sitter-mdx = { git = "https://github.com/jlopezcur/tree-sitter-mdx" }
18tree-sitter-json = { git = "https://github.com/tree-sitter/tree-sitter-json" }
19tree-sitter-python = "0.21"
20tree-sitter-md = "0.2.3"
21# tree-sitter-cobol = { path = "../../tree-sitter-cobol/" }
22
23[dependencies.notify]
24version = "5.0.0"
25default-features = false