diff options
author | bors[bot] <26634292+bors[bot]@users.noreply.github.com> | 2021-05-30 22:48:43 +0100 |
---|---|---|
committer | GitHub <[email protected]> | 2021-05-30 22:48:43 +0100 |
commit | d6490c69fb491fb11a3eaae84d24111784f5ce0c (patch) | |
tree | e3d442a47819943fb7f8c8cd3af3e2df7c6dccc5 /Cargo.toml | |
parent | 92b9e5ef3c03d51713ff5fa32cd58bdf97701b5e (diff) | |
parent | b12d8dcb828df8403b8f486f279f0eda3303a890 (diff) |
Merge #9069
9069: minor: Don't force-disable incremental r=jonas-schievink a=jonas-schievink
1.52.1 turns incremental off regardless of this setting, so this is unnecessary. Removing this allow manually overriding Cargo to enable incremental.
bors r+
Co-authored-by: Jonas Schievink <[email protected]>
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 7 |
1 files changed, 0 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml index 498cf7d62..e237b13dc 100644 --- a/Cargo.toml +++ b/Cargo.toml | |||
@@ -3,10 +3,6 @@ resolver = "2" | |||
3 | members = ["xtask/", "lib/*", "crates/*"] | 3 | members = ["xtask/", "lib/*", "crates/*"] |
4 | 4 | ||
5 | [profile.dev] | 5 | [profile.dev] |
6 | # We do want incremental builds, but they are broken at the moment :( | ||
7 | # https://github.com/rust-lang/rust/issues/85003#issuecomment-833796289 | ||
8 | incremental = false | ||
9 | |||
10 | # Disabling debug info speeds up builds a bunch, | 6 | # Disabling debug info speeds up builds a bunch, |
11 | # and we don't rely on it for debugging that much. | 7 | # and we don't rely on it for debugging that much. |
12 | debug = 0 | 8 | debug = 0 |
@@ -21,9 +17,6 @@ text-size.opt-level = 3 | |||
21 | miniz_oxide.opt-level = 3 | 17 | miniz_oxide.opt-level = 3 |
22 | 18 | ||
23 | [profile.release] | 19 | [profile.release] |
24 | # We do want incremental release builds, but they are broken at the moment :( | ||
25 | # https://github.com/rust-lang/rust/issues/85003#issuecomment-833796289 | ||
26 | incremental = false | ||
27 | debug = 0 # Set this to 1 or 2 to get more useful backtraces in debugger. | 20 | debug = 0 # Set this to 1 or 2 to get more useful backtraces in debugger. |
28 | 21 | ||
29 | [profile.test] | 22 | [profile.test] |