diff options
author | Aleksey Kladov <[email protected]> | 2021-02-17 14:53:31 +0000 |
---|---|---|
committer | Aleksey Kladov <[email protected]> | 2021-02-17 14:53:31 +0000 |
commit | 3db64a400c78bbd2708e67ddc07df1001fff3f29 (patch) | |
tree | 5386aab9c452981be09bc3e4362643a34e6e3617 /crates/completion/Cargo.toml | |
parent | 6334ce866ab095215381c4b72692b20a84d26e96 (diff) |
rename completion -> ide_completion
We don't have completion-related PRs in flight, so lets do it
Diffstat (limited to 'crates/completion/Cargo.toml')
-rw-r--r-- | crates/completion/Cargo.toml | 31 |
1 files changed, 0 insertions, 31 deletions
diff --git a/crates/completion/Cargo.toml b/crates/completion/Cargo.toml deleted file mode 100644 index 99a1bdd54..000000000 --- a/crates/completion/Cargo.toml +++ /dev/null | |||
@@ -1,31 +0,0 @@ | |||
1 | [package] | ||
2 | name = "completion" | ||
3 | version = "0.0.0" | ||
4 | description = "TBD" | ||
5 | license = "MIT OR Apache-2.0" | ||
6 | authors = ["rust-analyzer developers"] | ||
7 | edition = "2018" | ||
8 | |||
9 | [lib] | ||
10 | doctest = false | ||
11 | |||
12 | [dependencies] | ||
13 | itertools = "0.10.0" | ||
14 | log = "0.4.8" | ||
15 | rustc-hash = "1.1.0" | ||
16 | either = "1.6.1" | ||
17 | |||
18 | stdx = { path = "../stdx", version = "0.0.0" } | ||
19 | syntax = { path = "../syntax", version = "0.0.0" } | ||
20 | text_edit = { path = "../text_edit", version = "0.0.0" } | ||
21 | base_db = { path = "../base_db", version = "0.0.0" } | ||
22 | ide_db = { path = "../ide_db", version = "0.0.0" } | ||
23 | profile = { path = "../profile", version = "0.0.0" } | ||
24 | test_utils = { path = "../test_utils", version = "0.0.0" } | ||
25 | |||
26 | # completions crate should depend only on the top-level `hir` package. if you need | ||
27 | # something from some `hir_xxx` subpackage, reexport the API via `hir`. | ||
28 | hir = { path = "../hir", version = "0.0.0" } | ||
29 | |||
30 | [dev-dependencies] | ||
31 | expect-test = "1.1" | ||