aboutsummaryrefslogtreecommitdiff
path: root/crates/completion/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/completion/Cargo.toml')
-rw-r--r--crates/completion/Cargo.toml31
1 files changed, 0 insertions, 31 deletions
diff --git a/crates/completion/Cargo.toml b/crates/completion/Cargo.toml
deleted file mode 100644
index 99a1bdd54..000000000
--- a/crates/completion/Cargo.toml
+++ /dev/null
@@ -1,31 +0,0 @@
1[package]
2name = "completion"
3version = "0.0.0"
4description = "TBD"
5license = "MIT OR Apache-2.0"
6authors = ["rust-analyzer developers"]
7edition = "2018"
8
9[lib]
10doctest = false
11
12[dependencies]
13itertools = "0.10.0"
14log = "0.4.8"
15rustc-hash = "1.1.0"
16either = "1.6.1"
17
18stdx = { path = "../stdx", version = "0.0.0" }
19syntax = { path = "../syntax", version = "0.0.0" }
20text_edit = { path = "../text_edit", version = "0.0.0" }
21base_db = { path = "../base_db", version = "0.0.0" }
22ide_db = { path = "../ide_db", version = "0.0.0" }
23profile = { path = "../profile", version = "0.0.0" }
24test_utils = { path = "../test_utils", version = "0.0.0" }
25
26# completions crate should depend only on the top-level `hir` package. if you need
27# something from some `hir_xxx` subpackage, reexport the API via `hir`.
28hir = { path = "../hir", version = "0.0.0" }
29
30[dev-dependencies]
31expect-test = "1.1"