diff options
author | bors[bot] <26634292+bors[bot]@users.noreply.github.com> | 2020-08-13 11:10:03 +0100 |
---|---|---|
committer | GitHub <[email protected]> | 2020-08-13 11:10:03 +0100 |
commit | de1d93455f85747410efb69c28e0c1379e8e328a (patch) | |
tree | 20eb4df06fc99236a30a98bba8e7ea3200b87042 /crates/project_model/Cargo.toml | |
parent | 8870a5ea138bb4ba048140d90d728721c4b4ad4b (diff) | |
parent | eac24d52e672c0a9c118e8969bf1b839c3e7f1f3 (diff) |
Merge #5744
5744: Rename ra_project_model -> project_model r=matklad a=pksunkara
Co-authored-by: Pavan Kumar Sunkara <[email protected]>
Diffstat (limited to 'crates/project_model/Cargo.toml')
-rw-r--r-- | crates/project_model/Cargo.toml | 25 |
1 files changed, 25 insertions, 0 deletions
diff --git a/crates/project_model/Cargo.toml b/crates/project_model/Cargo.toml new file mode 100644 index 000000000..8d8d09387 --- /dev/null +++ b/crates/project_model/Cargo.toml | |||
@@ -0,0 +1,25 @@ | |||
1 | [package] | ||
2 | name = "project_model" | ||
3 | version = "0.0.0" | ||
4 | license = "MIT OR Apache-2.0" | ||
5 | authors = ["rust-analyzer developers"] | ||
6 | edition = "2018" | ||
7 | |||
8 | [lib] | ||
9 | doctest = false | ||
10 | |||
11 | [dependencies] | ||
12 | log = "0.4.8" | ||
13 | rustc-hash = "1.1.0" | ||
14 | cargo_metadata = "0.11.1" | ||
15 | serde = { version = "1.0.106", features = ["derive"] } | ||
16 | serde_json = "1.0.48" | ||
17 | anyhow = "1.0.26" | ||
18 | |||
19 | arena = { path = "../arena" } | ||
20 | cfg = { path = "../cfg" } | ||
21 | ra_db = { path = "../ra_db" } | ||
22 | toolchain = { path = "../toolchain" } | ||
23 | ra_proc_macro = { path = "../ra_proc_macro" } | ||
24 | paths = { path = "../paths" } | ||
25 | stdx = { path = "../stdx" } | ||