diff options
author | Aleksey Kladov <[email protected]> | 2020-08-13 16:42:52 +0100 |
---|---|---|
committer | Aleksey Kladov <[email protected]> | 2020-08-13 16:58:27 +0100 |
commit | 1b0c7701cc97cd7bef8bb9729011d4cf291a60c5 (patch) | |
tree | b69f0c9947d9cec522ce835d7213b21075fe6dcf /crates/ra_ide/Cargo.toml | |
parent | fc34403018079ea053f26d0a31b7517053c7dd8c (diff) |
Rename ra_ide -> ide
Diffstat (limited to 'crates/ra_ide/Cargo.toml')
-rw-r--r-- | crates/ra_ide/Cargo.toml | 39 |
1 files changed, 0 insertions, 39 deletions
diff --git a/crates/ra_ide/Cargo.toml b/crates/ra_ide/Cargo.toml deleted file mode 100644 index 2eb86755f..000000000 --- a/crates/ra_ide/Cargo.toml +++ /dev/null | |||
@@ -1,39 +0,0 @@ | |||
1 | [package] | ||
2 | edition = "2018" | ||
3 | name = "ra_ide" | ||
4 | version = "0.1.0" | ||
5 | authors = ["rust-analyzer developers"] | ||
6 | license = "MIT OR Apache-2.0" | ||
7 | |||
8 | [lib] | ||
9 | doctest = false | ||
10 | |||
11 | [features] | ||
12 | wasm = [] | ||
13 | |||
14 | [dependencies] | ||
15 | either = "1.5.3" | ||
16 | indexmap = "1.3.2" | ||
17 | itertools = "0.9.0" | ||
18 | log = "0.4.8" | ||
19 | rustc-hash = "1.1.0" | ||
20 | oorandom = "11.1.2" | ||
21 | |||
22 | stdx = { path = "../stdx" } | ||
23 | |||
24 | syntax = { path = "../syntax" } | ||
25 | text_edit = { path = "../text_edit" } | ||
26 | base_db = { path = "../base_db" } | ||
27 | ide_db = { path = "../ide_db" } | ||
28 | cfg = { path = "../cfg" } | ||
29 | profile = { path = "../profile" } | ||
30 | test_utils = { path = "../test_utils" } | ||
31 | assists = { path = "../assists" } | ||
32 | ssr = { path = "../ssr" } | ||
33 | |||
34 | # ra_ide should depend only on the top-level `hir` package. if you need | ||
35 | # something from some `hir_xxx` subpackage, reexport the API via `hir`. | ||
36 | hir = { path = "../hir" } | ||
37 | |||
38 | [dev-dependencies] | ||
39 | expect = { path = "../expect" } | ||