aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_ide/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/ra_ide/Cargo.toml')
-rw-r--r--crates/ra_ide/Cargo.toml39
1 files changed, 0 insertions, 39 deletions
diff --git a/crates/ra_ide/Cargo.toml b/crates/ra_ide/Cargo.toml
deleted file mode 100644
index 2eb86755f..000000000
--- a/crates/ra_ide/Cargo.toml
+++ /dev/null
@@ -1,39 +0,0 @@
1[package]
2edition = "2018"
3name = "ra_ide"
4version = "0.1.0"
5authors = ["rust-analyzer developers"]
6license = "MIT OR Apache-2.0"
7
8[lib]
9doctest = false
10
11[features]
12wasm = []
13
14[dependencies]
15either = "1.5.3"
16indexmap = "1.3.2"
17itertools = "0.9.0"
18log = "0.4.8"
19rustc-hash = "1.1.0"
20oorandom = "11.1.2"
21
22stdx = { path = "../stdx" }
23
24syntax = { path = "../syntax" }
25text_edit = { path = "../text_edit" }
26base_db = { path = "../base_db" }
27ide_db = { path = "../ide_db" }
28cfg = { path = "../cfg" }
29profile = { path = "../profile" }
30test_utils = { path = "../test_utils" }
31assists = { path = "../assists" }
32ssr = { path = "../ssr" }
33
34# ra_ide should depend only on the top-level `hir` package. if you need
35# something from some `hir_xxx` subpackage, reexport the API via `hir`.
36hir = { path = "../hir" }
37
38[dev-dependencies]
39expect = { path = "../expect" }