aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_prof/Cargo.toml
diff options
context:
space:
mode:
authorbors[bot] <26634292+bors[bot]@users.noreply.github.com>2020-07-22 12:44:05 +0100
committerGitHub <[email protected]>2020-07-22 12:44:05 +0100
commit2dd8ba2b21e3262f25e4245e37549206c8a3bc2d (patch)
tree6dfcadbf3b6a333777f22f54db773118bf1916d4 /crates/ra_prof/Cargo.toml
parent26932e0060b74525f74df5e31ae0c88997e5d667 (diff)
parent9ad41eb9085cd7ceaf479f659a7071df81059b7c (diff)
Merge #5487
5487: Setup global allocator in the correct crate r=matklad a=matklad It worked before, but was roundabout bors r+ 🤖 Co-authored-by: Aleksey Kladov <[email protected]>
Diffstat (limited to 'crates/ra_prof/Cargo.toml')
-rw-r--r--crates/ra_prof/Cargo.toml8
1 files changed, 0 insertions, 8 deletions
diff --git a/crates/ra_prof/Cargo.toml b/crates/ra_prof/Cargo.toml
index 2e60858f1..6c214501e 100644
--- a/crates/ra_prof/Cargo.toml
+++ b/crates/ra_prof/Cargo.toml
@@ -13,20 +13,12 @@ doctest = false
13ra_arena = { path = "../ra_arena" } 13ra_arena = { path = "../ra_arena" }
14once_cell = "1.3.1" 14once_cell = "1.3.1"
15backtrace = { version = "0.3.44", optional = true } 15backtrace = { version = "0.3.44", optional = true }
16mimalloc = { version = "0.1.19", default-features = false, optional = true }
17cfg-if = "0.1.10" 16cfg-if = "0.1.10"
18libc = "0.2.73" 17libc = "0.2.73"
19 18
20[target.'cfg(not(target_env = "msvc"))'.dependencies]
21jemallocator = { version = "0.3.2", optional = true }
22jemalloc-ctl = { version = "0.3.3", optional = true }
23
24[features] 19[features]
25jemalloc = [ "jemallocator", "jemalloc-ctl" ]
26cpu_profiler = [] 20cpu_profiler = []
27 21
28# Uncomment to enable for the whole crate graph 22# Uncomment to enable for the whole crate graph
29# default = [ "backtrace" ] 23# default = [ "backtrace" ]
30# default = [ "jemalloc" ]
31# default = [ "mimalloc" ]
32# default = [ "cpu_profiler" ] 24# default = [ "cpu_profiler" ]