aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_prof/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/ra_prof/Cargo.toml')
-rw-r--r--crates/ra_prof/Cargo.toml8
1 files changed, 0 insertions, 8 deletions
diff --git a/crates/ra_prof/Cargo.toml b/crates/ra_prof/Cargo.toml
index 2e60858f1..6c214501e 100644
--- a/crates/ra_prof/Cargo.toml
+++ b/crates/ra_prof/Cargo.toml
@@ -13,20 +13,12 @@ doctest = false
13ra_arena = { path = "../ra_arena" } 13ra_arena = { path = "../ra_arena" }
14once_cell = "1.3.1" 14once_cell = "1.3.1"
15backtrace = { version = "0.3.44", optional = true } 15backtrace = { version = "0.3.44", optional = true }
16mimalloc = { version = "0.1.19", default-features = false, optional = true }
17cfg-if = "0.1.10" 16cfg-if = "0.1.10"
18libc = "0.2.73" 17libc = "0.2.73"
19 18
20[target.'cfg(not(target_env = "msvc"))'.dependencies]
21jemallocator = { version = "0.3.2", optional = true }
22jemalloc-ctl = { version = "0.3.3", optional = true }
23
24[features] 19[features]
25jemalloc = [ "jemallocator", "jemalloc-ctl" ]
26cpu_profiler = [] 20cpu_profiler = []
27 21
28# Uncomment to enable for the whole crate graph 22# Uncomment to enable for the whole crate graph
29# default = [ "backtrace" ] 23# default = [ "backtrace" ]
30# default = [ "jemalloc" ]
31# default = [ "mimalloc" ]
32# default = [ "cpu_profiler" ] 24# default = [ "cpu_profiler" ]