summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorAkshay <[email protected]>2020-12-14 17:17:05 +0000
committerAkshay <[email protected]>2020-12-14 17:17:05 +0000
commit6e18a4da63a46a54b531422dcc80b46cba80490b (patch)
tree81b977ca8660b8d82a37f2f7594c85d1ad4bf41a /flake.nix
init
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..19f063e
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,19 @@
1{
2 description = "Project presentation for Finite Automata and Formal Languages";
3
4 outputs = { self, nixpkgs }:
5 let
6 pkgs = import nixpkgs { system = "x86_64-linux"; };
7 in
8 with pkgs;
9 {
10 defaultPackage.x86_64-linux = stdenv.mkDerivation {
11 name = "fafl";
12 src = ./.;
13 buildInputs = [
14 texlive.combined.scheme-full
15 gnumake
16 ];
17 };
18 };
19}